Scion xB Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
Bought this kit on ebay for my 2006 xB. It is a plug and play kit, but I still took it too a local motorsport shop to get them installed. They told me the kit works if you run power directly ,but for some reason they did not work in my car. I tried it myself and they didn't work only the high beam worked. Then I ran power directly to them and they worked. Anyone have any suggestions on how to get these to work in my car.
 

·
Registered
Joined
·
419 Posts
you just connected the wiring wrong thats all.

does this kit come with high beam or low beam only

because if you have low beam only then you have to do trial and error on the factory harnest to figure which one is low beam or high beam only
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #3 ·
It has a HID low beam and a regular high beam. When I plug my kit to the factory harness and turn on my headlights nothing happens and when I hit my high beams it turns on. ???????
 

·
Registered
Joined
·
419 Posts
the ground wire is the middle top of your factory harness

if your facing the harness the right side is the low beam positive

the left side is the high beam positive.

just try connecting them again.
 

·
Registered
Joined
·
206 Posts
yo i got the same kit. turn the clip that connect the power source to the ballast so that the clip is facing inside. just play with the connector at the ballast and it will work.

it like drive with high beam with it work. the bulbs didnt come with shield. you gonna need to make one for yourself
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top