Scion xB Forum banner
15741 - 15759 of 15759 Posts

·
Registered
2006 Scion xB Automatic
Joined
·
107 Posts
Got mine towed home last night.

In a horrible mood, I don't really wanna discuss, lol.
 

·
Registered
Joined
·
801 Posts
So I know about resetting maintenance light but my question is..........Are the speedo light and clock supposed to flash with the maint light? And it does this until I buckle my seat belt? Never had that combo action in other vehicles.
 

·
Old School xB Builder
Joined
·
1,723 Posts
Been sick with covid haven't done a damn thing

Sent from my pimped out xB
 

·
Registered
Joined
·
801 Posts
got a booster, trying to not get it again.......hope recovery going well.....


....aired up all 4 neglected tire pressures to what they should be
 

·
Old School xB Builder
Joined
·
1,723 Posts
got a booster, trying to not get it again.......hope recovery going well.....


....aired up all 4 neglected tire pressures to what they should be
You are far more trusting than I am.... No vaccination...

Sent from my pimped out xB
 

·
Registered
Joined
·
801 Posts
Vaccinations aren't new, had them for measles, mumps, polio, tuberculosis, chicken pox and flu....whatever trust I have is in God and science tho, not government. I got these because I chose to not because gov said to. Will be getting a shingles one at some point as well.
 

·
Registered
Joined
·
1,578 Posts
By now everyone had either their shot or have natural antibodies. Our bodies naturally will learn how to fight the new strains.

Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
801 Posts
I have and/or had the natural antibodies too.....about 5 months before my 1st pfizer thing in June and 2nd shot in July..........
 

·
xB Leaving Pit Soon
Joined
·
1,129 Posts
Replaced spark plugs. Indexed three of them to zero, and one of them to three fifty as I ran out of precise shims to use within the torque value.
 

·
Registered
Joined
·
801 Posts
did oil/filter and tire rotation last wknd....got a new blower fan to swap in this wknd. Hoping for strong silent type, lol. mine seems weak and ticking at the moment. been that way since getting box almost 2 yrs ago? wow, time flyz.....whopping 6000 miles in 2 yrs.
 

·
xB Leaving Pit Soon
Joined
·
1,129 Posts
did oil/filter and tire rotation last wknd....got a new blower fan to swap in this wknd. Hoping for strong silent type, lol. mine seems weak and ticking at the moment. been that way since getting box almost 2 yrs ago? wow, time flyz.....whopping 6000 miles in 2 yrs.
As a test, you can remove the squirrel cage fan and run the motor by itself to hear if the clicking went away. If you have the time, consider making a DIY post of the work.
 

·
Registered
2006 Shadow Micah Scion xB 5 speed
Joined
·
112 Posts
On 2nd thought, just might be boxing the Injen setup back up and just staying with oem/aFe setup. The oem intake sucks in air basically from the same area that the Injen sri does just up beside headlight instaed of below it. Wouldn't mind less clutter under the hood but not really worth the hassle and expense of another custom sized filter. Look for the Injen in a FS thread. Also have gone back to oem engine cover instead of the cf one because I just like the oem
OK, Injen short ram install...........caca..... The instructions say NOTHING about included filter not fitting if you have fog lights. No way to adjust piping around it. Will involve using a custom filter with angled flange or something with smaller diameter on the end and/or a shorter filter. I'll put the oem with aFe drop-in back on before going without fogs. Will have to get some more exact clearance measurements and see who will have suitable dry flo filter that will work.

Number 2 suck is the prongs of the pipe support are too long to give front of battery suitable clearance and will need a trim IMO. Based on test fit would be very close if not rubbing front of battery. Not acceptable.

What doodoo.....not wanting to put oem back on just to wait on a filter to show up but I guess that's what it'll come to. Not impressed but not surprised either.
On 2nd thought, just might be boxing the Injen setup back up and just staying with oem/aFe setup. The oem intake sucks in air basically from the same area that the Injen sri does just up beside headlight instaed of below it. Wouldn't mind less clutter under the hood but not really worth the hassle and expense of another custom sized filter. Look for the Injen in a FS thread. Also have gone back to oem engine cover instead of the cf one because I just like the oem one better. That too will be coming to a FS thread when I get around to it.
Mine fit with fog lights in.


Edit: Just say you said Injen, and not DC. My DC fit fine with fog lights.
 

·
Registered
Joined
·
801 Posts
response hidden inside quotes.......but yeah, DC must have different shape filter, shorter filter, the pipe is shorter or a different angle pipe to clear fog housing.
 

·
Registered
Joined
·
801 Posts
As a test, you can remove the squirrel cage fan and run the motor by itself to hear if the clicking went away. If you have the time, consider making a DIY post of the work.
Did the swap today but didn't take pics.....basically you......

  • remove glove box, kick panel and door sill plate.
  • remove the bolt in door jam to allow bottom of dash to move.
  • pull off trim piece from ecu, remove 2 bolts up top, release loom clip in dash trim
  • wiggle ecu out of the way towards center console with all plugs still in place
  • remove 5 screws around the front and bottom of blower cover and a clip on far side towards door jam
  • unclip the fresh/recirc rod on left side of cover and undo wiring connector on right side of cover
  • release 2 clips on top edge and get cover free
  • wrestle the cover past the lower dash by pulling out on dash enough to free the cover
  • reach up and unplug the fan motor from harness and move the cover off to the side by ecu
  • should then have access to remove the 3 torx screws holding blower/cage in housing
  • reassemble in reverse order

Wiped out 18 yrs of dust inside the housing before putting new blower in and also wiped out the cover before putting it back in place. After plugging in blower and getting cover back in place with the 1 unplugged harness on right side plugged back in, I turned key on and made sure it was good to go before putting back all the rest. Fan sounded great like it should and is noticeably stronger air flow now. Setting 1 now feels like 2 or 3 did before. Put all the rest of the screws back in (with none left over) put all the harnesses back in place. put ecu back in place and snapped it's cover back on. Glove box back in. kick panel and door sill back in and all good to go. Probably about time for a new cabin air filter but it looked pretty good after 2 yrs.(2yrs equalling 6k miles) The screen I added to fresh air openings has kept all crazy things out. Nothing but some dust and dirt and not much of that. Just tapped it clean for the time being. Paper still mostly white even. The service manual helped a bit but there is youtube video that was much more helpful finding all the screw locations and how to sneak the cover out.

Other info....this is $40 shipped 1yr warranty non-oem blower. None of them had any longer warranty and just cost more. IMO, it is not a big enough project to warrant paying to have it done or paying whatever crazy price it is for the oem one at a dealership. Online discount toyota oem parts place wanted $142 for oem. We'll see how it works out. That's what I did, others can do what they wanna do..............
 

·
Registered
Joined
·
801 Posts
Replaced the semi-dusty oem cabin air filter with a washable electrostatic K&N......part # vf2009........no, it does not require oiling and has a cool fresh scent of electrostaticness. I have one in my truck and have cleaning kit that has the electrostatic recharge spray. Also bought one for the wife's RAV4 while I was at it..................between the filter and new blower motor, interior air flow and filtering maintenance complete.
 
15741 - 15759 of 15759 Posts
Top