Scion xB Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
Alright guys I can't finally post this up since I have even posts lol. Well heres the deal, I recently bought an 04 xB 1st gen and I just did an oil change because it needed one and changed the air filter since it was real dirty. When I'm driving and I put the car in D and drive away the car is perfectly fine and normal but when i stop at a light and I have my foot on the break my car starts to shake and I can feel it throughout the car but not through the steering wheel. This only happens when I get stopped at a light.Can anyone help me out and tell me whats the problem?? My dad said it could be the timing belt or like the idle??
 

·
Registered
Joined
·
7,518 Posts
LOL^ My auto did that around 40K miles. I cleaned the air filter, changed the plugs to NGK Irridiums, Installed one of Randode's ground wire kits, and even reset the ECU. Not sure which one or which combination fixed it, but it went away after that. I'd start with resetting the ECU, especially if you went to a free'er flowing air filter (like a K&N), and cause it's free!
 

·
Registered
Joined
·
104 Posts
Discussion Starter #7
the car has 55k on it right now.

Oh and I don't have mods on the engine by the way its all stock.

I'm thinking about just taking it to the dealer to check it out
 

·
Ain't too Funk to Druck.
Joined
·
17,243 Posts
prolly needs an engine damper? my car shakes a lil when stopped at the stop light. but it doesnt bother me. the items i have in my glove compartment jiggles and makes weird noises. lol. yeah, get it checked by the stealership, just dont get charged a lot.
 

·
Registered
Joined
·
104 Posts
Discussion Starter #9
my car shakes pretty good. I just turn up the music so I don't have to hear it lol..do scions have engine dampers? sorry if these are noob questions that im asking
 

·
Registered
Joined
·
130 Posts
I just nudge it into Neutral when rolling to a stop. All that vibration will disappear. Of course double check you didn't knock a connector or vacuum hose loose when you changed the air filter.
I've tried two different CAI, three types of spark plugs, new PVC, the 2001 Corrolla T/B, and driving with and without my fat G/F. Still have that engine vibration when in D and stopped. 114,000 miles. My kids XB is completely stock with 60,000 miles and its vibration is barely noticeable.
I guess what I am trying to say is I have no idea why some of us have very noticeable vibes and others don't.
 

·
06.5 TCM
Joined
·
10,027 Posts
It may be time to look at the spark plugs, may be clean MAF sensor and try top engine treatment (like seafoam).
I think adding an aftermarket dumper will transfer more vibration from the engine into body.
 

·
Registered
Joined
·
104 Posts
Discussion Starter #13
I'll probably take a look at the spark plugs since i don't know when it was last changed before i bought it. I use an engine treatment called Prolong for my other cars, have you guys heard of it? and is it any good? Its helped bring down the vibration a bit but its still there..
 

·
Registered
Joined
·
5 Posts
I just got a 2005 xb with 75,000mi and I think I am having the same problem. In park or neutral it's fine, but when in D or R it shakes pretty noticably. It mainly on the drivers side and it with the A/C on or off. It had an oil change pretty recently, new air filter and I think new plugs at 60,000mi.
I like what's been posted so far, I just wanna know if this sounds the same and if any of the options posted have worked for someone else with this problem. Thanks!
 

·
-EC HFD YO-
Joined
·
6,809 Posts
when i first read this, the first thing that came to mind was a bent rotor(s). it only happens when you brake sooooo :confused::confused:
but i could be wrong.
 

·
Owhat?
Joined
·
64 Posts
my xb is starting to vibrate a lot now as well. have 60k miles on it and changed the spark plugs even cleaned the MAF sensor and its still doing it. before i cleaned the MAF sensor the rpm's were dropping really low. it doesnt drop any more but its still vibrating a lot when im stopped esp. when i have the a/c on. i dont know what else to check so im about to head to the dealership for this:(
 

·
Registered
Joined
·
104 Posts
Discussion Starter #20
i went to the dealership they checked it out and found out it was the motor mounts that were damaged so i got it replaced and now theres alot less vibration than before. so it could be your motor mounts maybe??
 
1 - 20 of 35 Posts
Top