Scion xB Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
has anyone experienced any issues with the head unit in the green box mine ismessed up when i put a dvd in you can see it on the screens but i sounds like a movie reel is rolling and no sound will come out of speakers just that annoying clicking noise please help me the dealers in connecticut don't seem to know crap they are telling me that the stock alpine unit is an aftermarket radio because they didn't install it at the dealer what a bunch of jerks well any help from the club xb family would be good
 

·
Registered
Joined
·
199 Posts
I'd try to get a hold of Alex. grizzly_choppers, on here, not only does he work at a dealership, was in parts, now up front, but he owns and rs 3, and an rs1, so not only does he know the alpine unit is stock in the rs3 but he can tell you what you need to do to get it fixed, sounds like the dealers there are trying to jerk you around.

PS Alex is down in Tulsa at the Scikotics Asylum show this weekend so I'd wait until monday.
 

·
Registered
Joined
·
260 Posts
I'm not an expert, but that sounds like a bad connection, if that is a new install, I'd check the connections first, most install shops rush the work, as they get paid by the job. Most of the time they use crappy crimp style connectors, and they can uncrimp right away, check it out, usually wiggling wires while the unit is on, you will notice which wires are poorly connected. They best way on high power systems, is to solder and heat shrink all connections.but then that is just my opinion, I hate like hell to have a sound problem while out cruise'n on a saturday night.
Good luck!
 

·
Banned
Joined
·
528 Posts
I have problems with my speakers. THEY ARE SUPER QUITE............ I go down the highway and have to completley blast the speakers to even hear anything. I know they are super quite when they are on duel but is there another mode I am missing? The Alpine speakers should not be quite at all
 

·
bB SQUAD!!!
Joined
·
2,793 Posts
the one thing i hate about mine is the fast forward button... that thing wont work for me, when i listen to cds and want to fast forward (not skip to next song) i would hold down on the button and it wont do anything... its like im pressing the wrong button but i've tried both up/down/right/left arrows and nothing works... ok, sometimes, fine, rarely the fast (up arrow) will work but not the down...

i see we are having different issues with that radio... dont get me wrong i love the features but that one function...
 

·
I'm a chick, yo!<3
Joined
·
447 Posts
xBx29xEF said:
the one thing i hate about mine is the fast forward button... that thing wont work for me, when i listen to cds and want to fast forward (not skip to next song) i would hold down on the button and it wont do anything... its like im pressing the wrong button but i've tried both up/down/right/left arrows and nothing works... ok, sometimes, fine, rarely the fast (up arrow) will work but not the down...

i see we are having different issues with that radio... dont get me wrong i love the features but that one function...
yah that is what is wrong with mine! i don't have a fast forward button that actually works....i don't know if the side arrows do that fast forwarding or not but i couldn't find it in the book...sometimes i just wanna get to a certain point of a song
 

·
bB SQUAD!!!
Joined
·
2,793 Posts
okay, i just discovered that mine would not play "enhanced CDs"... WTH...
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top