Scion xB Forum banner

1 - 9 of 9 Posts

·
Lonely in SoVA
Joined
·
7 Posts
Discussion Starter #1
Hey guys, I'm wondering if anybody else has had or does have the same problem that I've got... So for basically as long as i can remember since I've had my xB, it has occasionally made a grumbling/grinding noise when I lightly accelerate from about 32-49MPH, and if i let off the gas pedal it goes away, and if i press it harder and rev the engine higher it goes away as well. When it's in the process of making the sound, it usually won't really accelerate much, and the main time this happens is while going up hills, where I'm trying to maintain my speed without giving the car a lot of gas. It has been happening very frequently over the last two months or so, and although it doesn't directly affect the way the car gets from point A to B, I'm afraid that if I leave the problem unattended for too long, it'll end up costing me a bunch of money that I may not be able to afford. I did a little research for general vehicles with similar problems and discovered that the torque converter could be the root of this problem, but I'm not very sure what that would mean/what all would have to be done to the car for the problem to stop. If anybody has any knowledge or information about this issue, or if you have the same problem, I'd like to hear it, maybe it could help fix whatever is going on. I've got an '09 xB, 175k miles. Thanks guys!
 

·
Lonely in SoVA
Joined
·
7 Posts
Discussion Starter #2
Well, close to a year later I decided it was time to swap the whole transmission at 198k, so last week I went and picked up a used transmission and me and a friend did the swap. Long story short, the transmission I got was bad, so I had to go and pick up another one and then this past weekend we did the swap a second time, and this time the transmission was great, and now I have no more shuttering, no more jerking and surging while going up steep hills, and reverse works great. Turned out to be the torque converter was going bad, but I'm not sure why. I don't know of any other xBs that have had this problem, so mine must have been a random happening. Just in case anyone else is considering swapping out the transmission themselves, it isn't terrible, and I could give a few helpful tips if needed, especially on how to actually get the transmission to drop out of the engine bay. Hope nobody else has this problem!
 

·
Registered
Joined
·
7 Posts
I'm basically a total newbie with cars. This was my first purchase and I bought it used with 149x seemed great and then I noticed it doing the exact same thing yours is doing. So my question is can the torque converter be replaced on its own or is it something that requires the entire transmission be replaced?
 

·
Registered
Joined
·
26,572 Posts
Do any one of you know IF transmission was ever serviced ????? Just like getting your engine oil changed , it must be done from time to time !!!!
 

·
Registered
Joined
·
1,375 Posts
Do any one of you know IF transmission was ever serviced ????? Just like getting your engine oil changed , it must be done from time to time !!!!
Agreed, how I service mine is every 30k do two drain and fills, NO FLUSH!!!!

Sent from my SM-G930T1 using Tapatalk
 

·
Registered
Joined
·
7 Posts
I have no idea if mine was ever done. I bought the car used with 144x miles on it. I'd assume seeing what mechanical records I saw for it that the previous owners had it done. Per the carfax it was a one owner before me. Purchased at the same dealership that they had it serviced at for the first like six years they owned it.
 

·
Registered
Joined
·
26,572 Posts
If you assumed that then you most likely are wrong !! I am second owner of mine with just about 89K on her !! XB will be 13 years old this month and have owned her for the last 11 !! I had mine done 5 years ago and will be done in the 2. Do the tranny oil change and see what happens ?? Cheaper than a transmission !!!
 

·
Registered
Joined
·
7 Posts
I'm taking it to a shop today. We checked all the fluids when we purchased it checked everything again. The transmission fluid was the cleanest I'd ever seen so I mean it had to have been done at some point. My car is having far more problems then the OPs was. I have the issue he stated but recently it's also been slow on the accelerate and slow to down shift. It also makes a jerking/grinding thing when you give the car any gas in reverse, fine if your letting gravity do it's thing but as soon as you give it gas in reverse it's like the car no longer knows how to go.
 
1 - 9 of 9 Posts
Top