Scion xB Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Just bought my daughter a 2006 xb with 187k for her first car. We paid $1850 for it. It has a few issues going on with it, first problem I'm gonna have to weld the exhaust brackets back on the exhaust. Second there is a wobble in the front end at all speeds. Hopefully it's just bad tires and not wheel bearings....I'm learning ng towards the bearings though...mainly cause there is a constant woosh sound inside the cabin while driving. Lastly it has the dreaded broken hatch latch that is pulling away from the hatch. None the less a little tlc and this will be a great car for her to learn on.

Looking forward to being a part of the forum and learning about these rigs!



Sent from my LM-G820 using Tapatalk
 

·
xB Leaving Pit Soon
Joined
·
809 Posts
Just bought my daughter a 2006 xb with 187k for her first car. We paid $1850 for it. It has a few issues going on with it, first problem I'm gonna have to weld the exhaust brackets back on the exhaust. Second there is a wobble in the front end at all speeds. Hopefully it's just bad tires and not wheel bearings....I'm learning ng towards the bearings though...mainly cause there is a constant woosh sound inside the cabin while driving. Lastly it has the dreaded broken hatch latch that is pulling away from the hatch. None the less a little tlc and this will be a great car for her to learn on.

Looking forward to being a part of the forum and learning about these rigs!
Welcome to the website. The Black Cherry Pearl (BCP) is my favorite color. She looks solid and no apparent rust; the WV roads have been kind to her. Hopefully the bearings are okay. You can switch the front wheels to the rear and see if the noise follows the tires. Used parts are reasonably available on this site since a lot of modifications were performed on xB's. There are also a lot of postings as well as experienced personnel who may provide information on mods, repairs, and maintenance. My daughter in KY enjoys her 2005 BCP. Do you and your daughter have any mods planned for her xB?

Frank
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanks for the welcome Frank. Surprising enough there isn't a bit of rust that I could see underneath it....lol that being said the 1.5 mile washboard gravel road that we drove down to get to it has probably taken a toll on most of the suspension...lol but all of that I can deal with. Since this is her first car we wanted something with a timing chain and something that would get her at least 50k on top of the 188k and that little Toyota vvti is a great engine. The rest we can work around.
I don't have really have any plans for mods, just swap all the lights with leds. The headlights are most important for right now. Not that she will be doing any night time at first but I just wanna get that out of the way.

I'm gonna get this little thang legal then take it to a tire shop to see what's going on. Then it's off to an exhaust shop to get the pipes welded back to hangers....this thing is so low to the ground that I can't fit underneath let alone get my flux core in there. One thing I noticed is the rear shocks are toast so that's going on the list. An oil change....yup, annnnd it's been the windshield has been a bullseye for rocks on the interstate....there probably 4 really good ones that I'm gonna have to fill.

Lol other than that and praying it doesn't need wheel bearings, there is a very loud metal vibration coming from the front passenger side near the floor board. Kind of sounds heat shield rattle...but times 20. I saw that the exhaust runs down the middle so I'm not sure what it could be.

Anywho that was long winded lol.

Sent from my LM-G820 using Tapatalk
 

·
xB Leaving Pit Soon
Joined
·
809 Posts
A heat shield rattle has been incurred by several members. Usually it is a matter of an easy reposition or slight bending. Occasionally there may be a rusted through support. Either way, an easy fix. The engine should readily achieve the longevity and mileage you want. I completed the last switch from incandescent to LED this past weekend in KY. Lots of good choices for LED headlamp bulbs as well as all the other bulbs. If you switch the turn signal bulbs out, it may, or may not, be necessary to change the flasher relay as the reduced current draw can cause too rapid of a flash.

Keep everyone updated.
Frank
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
I'm gonna try and get under it tomorrow and find the issue...also a quick update I ran outside to check the tire pressure and....without adieu all of them were way off, most of them were under 20 psi...which might explain the horrible ride home lol.

I like hikari leds I have them in my Nissan frontier Pro4x. I probably won't swap the turn signals...I don't wanna have to add relays etc...
Watched a video on the hatch latch and rear shock replacement, those are 2 easy fixes I can do lol.

I think I'm already getting obsessed lol. Gonna see if this thing is pre wired for fogs and if so that will hit my list as well.

The clear coat on the roof is horrible, I was thinking about plastidip...but not sure if I wanna go that route, mainly cause I would be using a rattle can and I don't want striping.

Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
26,572 Posts
Welcome to da club !! Your xB is wired for the fog lamps !! Run them tires up 40 PSI to max out MPG !! Just do your maintenance and you should get many more years out of her !!! Let the mods begin !!!!
 

·
xB Leaving Pit Soon
Joined
·
809 Posts
I probably won't swap the turn signals...I don't wanna have to add relays etc...
No relays to add; simply switch out the OEM flasher to one which operates steadily on the LED lighter current draw. It is also possible you would not have to switch if the LED bulbs work at the correct rate with the OEM flasher.

"I think I'm already getting obsessed lol" Yes sir; that is how it begins, and on it goes.

Frank
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Ok not quite a build thread yet.

Swapped out the plugs, and changed the oil.
those things were toast! Idles and sounds so much better! Although....this happened!
the snaps broke off the wire harness to the coil packs. They are pretty tight on there but I'm a little nervous they will wiggle off over time.

I put 40 psi in all the tires and it didn't help. I've either got bad wheel bearings or bad tires.

I'm driving it to work tomorrow and then to get the exhaust fixed. Then next week it's off to the dealership to see exactly what I need to get fixed.



Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
Got this thing on a rack today, exhaust is back as it should be.


But as I was underneath checking stuff out I noticed this
Dang! I'm gonna try to tighten it with an actual filter wrench as u only hand tightened it when I changed the oil...which is what I thought you were supposed to do....but a little extra torque will hopefully seal it up

Sent from my LM-G820 using Tapatalk
 

·
xB Leaving Pit Soon
Joined
·
809 Posts
You can loop a plastic tie-wrap around the bolt of the COP and between the wires on the connector. It should last a long time even with the engine heat.

Possibly some dirt got on the filter gasket, or the base, when putting the filter on. When installing an oil filter, put a thin coat of oil on the filter's rubber gasket and go no more than 1/3 to 1/2 turn further after contacting the base. Please do not use a filter wrench to tighten the filter; only use one to remove a filter. Often when one is used to tighten, much unhappiness is visited upon the next oil change when trying to remove the filter.

You are making great progress with the xB.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
Had the tires rotated and balanced and she drives smooth now...but that noise is still there....verdict after lifting it up and spinning the tires...bad rear passenger wheel hub! I will be changing that out next weekend.

...then it's time to tackle the squeaky belts!

Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
26,572 Posts
Just a thought here is did you get any records when things were done ?? Like trany serviced new belts or water pump !!!

Just thinking out side the box !!!
 

·
Registered
Joined
·
2,587 Posts
And always make sure the old oil filter gasket comes off with the filter. Years ago I changed oil and filter on a car. Didn’t check the sealing surface on the motor. There was an old gasket stuck to the block. Filter I took off still had its gasket. It blew out on the interstate and gave everybody a scare.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #16
Just a thought here is did you get any records when things were done ?? Like trany serviced new belts or water pump !!!



Just thinking out side the box !!!
Service records are something that I look for in every vehicle. Unfortunately and I don't know why but most people don't keep them. The lady said that the auxiliary belt had been changed and I looked at it and it was new. However the belt underneath that one...not sure if that's the one for the water pump... But that one is definitely old. I'm gonna take it to the dealer for inspection and have them look everything over.

Sent from my LM-G820 using Tapatalk

---------- Post added 08-04-2019 at 02:04 PM ----------

And always make sure the old oil filter gasket comes off with the filter. Years ago I changed oil and filter on a car. Didn’t check the sealing surface on the motor. There was an old gasket stuck to the block. Filter I took off still had its gasket. It blew out on the interstate and gave everybody a scare.
I look it over before putting the filter on. That definitely is scary!

Sent from my LM-G820 using Tapatalk

---------- Post added 08-04-2019 at 02:06 PM ----------

Things keep going south lol...but that can be expected with any high mile 13 year old vehicle....while trying to fix the chips in the windshield the last one that needed fixed did this.
guess we will be in the market for a new windshield.

Sent from my LM-G820 using Tapatalk
 

·
Registered
Joined
·
26,572 Posts
My xB just turned 14 last month and I do have a chip in my windshield but I refuse to change it out as it is OEM !!! A few years ago I had all the belts changed so I would not have to think about it !! G/L !!
 

·
Registered
Joined
·
1 Posts
I bought this 06 Scion last Thursday and I fell in love with the vehicle. I paid 6,500.00 for it,but it only has 41,000 miles. She's just now getting broke in. The handling is phenominal with almost no turning radius. We took it up to North Carolina with no issues at all. I always wanted a little Scion but I didn't know how good they were. They have room galore in the cabin with a good sized cargo space. Good luck and God bless you in your ownership of a Scion.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #20
Lots of things have happened since my last post. I posted this over on the f.b. customization page.

Where to start...

Swapped the rear passenger hub assembly which was a disaster but I did it.

Snapped the brake line in the process...had to run o O'Riley auto parts to get a new one.

I wish I would've done both sides but that side was such a pain that I'm waiting.

Got a new windshield for $176 and installed in like 30 minutes


Still had a super smell like nasty air fresheners and I couldn't get it out. So I removed the floor console and found this....
mice had been through this thing.... I cleaned all that out, shampooed the seats and now it smells alot better in there.

Going for an inspection this Tuesday at the dealership to find out what else is going on with it...if anything.

Sitting decent for now!!!!


Sent from my LM-G820 using Tapatalk

---------- Post added 08-17-2019 at 10:58 PM ----------

....that was too much editing lol
Here's the real pic!


Sent from my LM-G820 using Tapatalk
 
1 - 20 of 21 Posts
Top