Scion xB Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
The driver side brake light on my 05 ist gen xb is not working. the bulb is new and the fuse is good. any ideas of why the brake light wont come on? im looked all over the threads and have had no luck. :confused: some one help me plz dont want a ticket!;)
 

·
Ain't too Funk to Druck.
Joined
·
17,243 Posts
Check to see if you put the bulbs back in place correctly. And make sure they snap snug in place. Its prolly a pinched wire also, check that. This happened to me quite a few times awhile back. Good luck :)
 

·
RS4 #303
Joined
·
4,900 Posts
how do i check for a pinched wire?
sometimes when you remove the taillights a wire will get pinched between the body and light housing when reinstalling. also check each metal tab on the sockets (bend them up a little to insure they are making connection on the circuit board.

---------- Post added 08-26-2013 at 12:19 PM ----------

Also you can clean the contacts on the circuit board with a SOFT eraser to insure good connection.


 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
sometimes when you remove the taillights a wire will get pinched between the body and light housing when reinstalling. also check each metal tab on the sockets (bend them up a little to insure they are making connection on the circuit board.

---------- Post added 08-26-2013 at 12:19 PM ----------

Also you can clean the contacts on the circuit board with a SOFT eraser to insure good connection.


THANK YOU! THIS WAS THE FIX. THE CONNECTORS WHERE VERY DIRTY CAUSING POOR CURRENT. :):):p
 
1 - 6 of 6 Posts
Top