Scion xB Forum banner
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
336 Posts
Discussion Starter · #1 ·
is any one else having problems with the heater knobs getting stripped im going on my 3rd time i went to use my heater and i turn the knob and it jumps back to the middle so right now my heater is not working anyone else have the prob at all . the toyota dealer wants to charge me 95 bucks just to c whats making it do that but i dont wanna pay that anyone know what it may be
 

·
I am Sofa King We Todd Ed
Joined
·
3,453 Posts
The only knob I have an issue with is the one to the far left. It doesn't sit all the way to the right unless I pull the knob out a bit and then finish twisting it. Since that's as bad as it is right now, I haven't been worried to even open up the dash.

Let us know if you find anything out man!
 

·
Registered
Joined
·
1,985 Posts
Have you taken the dash apart to mess with anything back there?

If so did you have the knob come apart on you? If I recall there was a spring and some ball bearings that can make the knob act all funky if they come out and don’t go back in the right way.
 

·
Registered
Joined
·
1,456 Posts
First take the speedo trim out with the one plastic phillips that holds it in. Next remove the plastic bezel to gt to the 3 cadium plated phillips...remove them and the speedo housing. Look directly down and you'll see the end of the heater cable. Something is jarring it right there from making it's full travel (ie. wires, fm modulator, line output converter, sat radio thing...etc) PM me if you have any trouble with this and I can help. I take apart my car and a whole bunch of others all the time:D
 

·
TheOtherGuys
Joined
·
7,988 Posts
I need to check mine, I noticed it won't go all the way to the right (full hot). But I have been under the dash multiple times, even had that cable off.
 

·
Registered
Joined
·
546 Posts
i have the same problem except mine doesnt go all the way back to the middle it goes like in between the middle and hot..
 

·
Registered
Joined
·
336 Posts
Discussion Starter · #12 ·
scvscions said:
First take the speedo trim out with the one plastic phillips that holds it in. Next remove the plastic bezel to gt to the 3 cadium plated phillips...remove them and the speedo housing. Look directly down and you'll see the end of the heater cable. Something is jarring it right there from making it's full travel (ie. wires, fm modulator, line output converter, sat radio thing...etc) PM me if you have any trouble with this and I can help. I take apart my car and a whole bunch of others all the time:D

thank u i did what u told me and the cable needed a little hepl moving for some reason and now it works thanks alot guys for ur input it saved me 95 bucks
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top