Scion xB Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
420 Posts
Discussion Starter · #1 ·
Ok I Have Been Having Problems With M Yxb Its Really Really Weird And Was Wonderin If Any Of U Have Any Suggestions..
Ok Everyonce In A Whiel My Traction Control Check Enginelight And Tcs Or Some Other Botton Comes On
After A While It Will All Be Ok ..
But Give It Some Time Then The Traction Control Go's Out With Check Engine Light On And The Other Botton
What The Hck?
I'm Trying To Get To The Bottom Of This!
 

·
Registered
Joined
·
352 Posts
traction control, vsc and check engine?

sounds dumb but have you checked to make sure your gas cap is tight?
 

·
Registered
Joined
·
352 Posts
would also check to make sure your wheel speed sensors arent grubbed up and theres no metal flakes that would alter the magnetism. that and they are fully plugged in
 

·
scikotics
Joined
·
1,005 Posts
yep what he said. First check your gas cap. Also I've heard if you top off your tank it can cause these problems also. Not sure way that is. Just heard from someone on this site said he had that problem. Good luck
 

·
HORNBLASTER
Joined
·
446 Posts
Do u have a air intake on ur xb . If so go and make sure ur all ur clamps are tight on it and maybe try checkin ur mass air flow sensor. If ur ur tripin ur check engine light u may try goin to auto zone and see if the have a scanner for codes .I know auto zones down here will come out put there scanner on ur car for free and tell u what code it is. If u get a code number u can post it on here im sure some of us on here will be able to help ya out or at least tell ya were to look for the problem.
 

·
Registered
Joined
·
194 Posts
iheartmyxb said:
ok gas cap wasnt the problem.. =(
help me fix it..

how many starts/stops did you have since you checked the gas cap?
it usually takes as many as 5 start/stops for the light to go out.
 

·
scikotics
Joined
·
1,005 Posts
Go out get in your box and push the odometer button in and hold it in while you turn your key to the on position. That should reset it if that is the problem. If that's not it take it to the dealer. Hope this helps.
 

·
Registered
Joined
·
352 Posts
^^ what he said will do nothing.

thats just a maintenance light that ur resetting. dont do that
 

·
Registered
Joined
·
352 Posts
this is a warrenty covered problem. take it to the dealer. have em hook up the mastertech, find out the real problem.
 

·
scikotics
Joined
·
1,005 Posts
the brave little toaster said:
^^ what he said will do nothing.

thats just a maintenance light that ur resetting. dont do that
My bad. I mis read I thought she said she hit the 5,000 mile thing. I see she said the 5 stop/start thing. :eek: Brain dead today I guess.
 

·
Registered
Joined
·
491 Posts
im having the same problem with the check engine light and the vsc and the traction control light on the dash, i tried taking out the short ram intake and installing a cold air, but after i was done all the lights apeared on the dash! plus my engine is bogging like crazy at 1500rpm, does anyone no if the maf is the problem?
 

·
HORNBLASTER
Joined
·
446 Posts
sounds like check maf connector then check make sure all ur clamps are tight with no air leaks listen for air being sucked in some were not suposed to be
:)
 
1 - 20 of 31 Posts
Top