Scion xB Forum banner
Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, new to this forum. I just bought a 2005 XB from a private owner but I seem to have problems when gassing up. I can't get the hose to continually fill without stopping every few seconds. It works a little better if I hold it the entire time, but not much. I've tried various angles but nothing seems to help. Is this a known issue or am I the only one? Any suggestions?

Thanks guys!
 

·
mertechperformance
Joined
·
1,478 Posts
danbaldwin777 said:
Hello, new to this forum. I just bought a 2005 XB from a private owner but I seem to have problems when gassing up. I can't get the hose to continually fill without stopping every few seconds. It works a little better if I hold it the entire time, but not much. I've tried various angles but nothing seems to help. Is this a known issue or am I the only one? Any suggestions?

Thanks guys!
yea it's a tsb . if you still have less thanm 36k miles it will be fixed for free. if not you are sol , you can pay for the new tank and labor but that's gonna be at least 600.00
 

·
TheOtherGuys
Joined
·
7,988 Posts
My 05' doesn't give me any problems, this is the first time to hear about it. Have you tried other pumps?
 

·
TheOtherGuys
Joined
·
7,988 Posts
Got mine in Dec 04', I'll have to pay more attention next time I fill-up. Maybe I've just gotten used to it or something.
 

·
mertechperformance
Joined
·
1,478 Posts
well if yer tank is an old tank you cannot use the automatic pump feature except at maybe 10% of gas stations.
 

·
TheOtherGuys
Joined
·
7,988 Posts
I must have the new tank, I'm able to hang out and let it pump by it's self. Not that it takes a long time to fill up or anything. And I'm starting to like the gas prices.
 

·
Registered
Joined
·
1,105 Posts
madmaxb said:
:D wow thanks thomas how u find all this info u work for toyota :D
Heheheheh... I've never worked for Toyota or any car-related company. I'm a retired technoid (ex-engineer/manager/CTO) that just likes to have good solid data on hand.

Tomas
 

·
Registered
Joined
·
611 Posts
is this fixed for the MY06's?
 

·
Registered
Joined
·
1,105 Posts
Yes, it was fixed part way through the '05 model run.

Tomas
 

·
Registered
Joined
·
611 Posts
i agree! :D

my old MY04 had this problem.

infekted said:
Tomas is the MAN when it come to this stuff! Good work as always Tomas!!
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top