Scion xB Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Back story: As the title suggests, I have a dim headlight as well as a dim daytime running light. The ones on the driver's side are fine. I have already checked all my fuses and they all are fine. I have also swapped the bulbs from the driver's side (the ones that seem to work) over to the passenger's side. They were still dim even though I know they work. My last resort was to check the grounds and clean them. Sure enough, there was a fair bit of rust. I cleaned up all the rust and sprayed some electrical contact cleaner.

After all this, the headlight and the DRL on the passenger side are STILL dim. I have checked all throughout these forums and several google searches. Still can't find a way to fix it. I've even thought it might possibly be the wiring harness, but I'm not too sure. I've almost given up and am just about ready to take it to the shop. This forum is my last resort. If any of you know any possibilities to fixing the issue or any troubleshooting, please feel free to reply. Thank you all in advance for your replies!
 

·
Registered
Joined
·
2,697 Posts
Have you checked to make sure you have same voltage to bulbs on each side? Could be a loose connection on power side
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thank you for the reply! I have yet to check the voltage. I'll try that and see where it gets me. Where is the possible loose connection on the power side located?
 

·
Registered
Joined
·
143 Posts
Just a thought; does the xB have the same parking lamp switching arrangement as the bB? If so, does the dim lamp issue happen when the indicator stalk is set to that side when the car is parked, ignition off?

If yes, then try pulling out the relay that connects the indicator switch into the stud diodes that allow only the lamps on the selected side of the car to operate. This issue can also fool us into thinking that there's a bad earth on the indicators as any reverse current at the stud diodes will cause some leakage from the parking lamps to the indicators on whichever side the faulty stud is found.
 
1 - 6 of 6 Posts
Top