Scion xB Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
32 Posts
Plenty of info out there on this topic already. You need to have it scanned for codes. Many times this will turn out to be emissions-related, but that's not the only possibility. The codes will give you an idea of where to start.
 

·
Registered
Joined
·
8 Posts
Try checking to see if the gas cap needs to be screwed back on tight. And/or inside the gas door might need a cleaning. This problem started with my 2006 xB about five years ago. Had the sensor replaced at the dealer. Still does this off and on. Usually it's gas cap related now.
 

·
Registered
Joined
·
28 Posts
Story time!

Hmm, mine came on (ain’t going to say this will happen to you) and I changed rotors (front), pads, spark plugs, made sure the coil packs were on right, checked the gas cap, still stayed on, well, I used to sleep in my car and it was winter so I would say I did idle it longer than I should and not knowing as back when I got it I should have done research but failed to do so, and so I though after about 10 full tanks in, why not try a higher octane to clean the gunk out so she won’t have build up, car started acting up horribly and then I did research, I wasn’t supposed to put anything other than regular in the tank because it destroys the catalyst, found she won’t run at top notch but she will run and after buying and putting on bank 1 sensor, smooth she ran, finally this stimulus check came and I bought a replacement exhaust since the whole thing looked rotted, ran’er open headers (idle sounds good but acceleration is no bueno) finally got the exhaust on and Bosal sucks let me just add that, looked identical but the fit was not and finally the lights went off. The End.
 

·
Registered
Joined
·
13 Posts
My wifes 06 will do that if she doesnt use at least 89 octane and gas without ethanol. It sounds stupid but since she has been doing that I havent had to reset her CEL in about a year or so.
Also if you havent driven it in a while it might just be trying to remap sensors and so it ran rough, knocked and set off the light. My 05 does that from time to time. I run 91 in mine.
 

·
Registered
Joined
·
28 Posts
Idk what it was, after I done all that though the lights went off and she’s been running fine, but there’s one thing I really ain’t sure about, when I was changing the cat, the front o2 sensor had white all over it meaning it’s been in contact with coolant. Why would there be excess coolant there? Also, (idk if it’s true or not) but read that you can clean them, one method was to let them soak in gasoline over night and let air dry and then someone else said you can plug it back up and with the extreme heat, it’ll burn it off. But after plugging back up, no codes..
 

·
Registered
Joined
·
2,670 Posts
Did you ever have the codes read? VSC and Trac Off can usually be traced to damaged wiring or speed sensor at the wheels
 

·
Registered
Joined
·
2,670 Posts
Unclbu for the Traction and Stability lights. The Evap code has been traced to several known issues. Gas cap not sealing properly. Deteriorated hoses on the evap canister located under the tail end of our xB's. Also hose issue at solenoid under the hood. These are the 3 main issues that I remember members having issues with.
 
  • Like
Reactions: A.J. Callahan

·
Registered
Joined
·
366 Posts
Mine was cracked hose under the hood going from throttle body to return line going back to tank. Replaced that hose and all lights went off immediately.
 

·
Registered
Joined
·
28 Posts
Hm. I actually didn’t know that, I’ve searched for answers and I mean, that will help in the later future if it arises again. Thank you for sharing that wagonbldr.
 

·
Registered
Joined
·
2 Posts
Unclbu for the Traction and Stability lights. The Evap code has been traced to several known issues. Gas cap not sealing properly. Deteriorated hoses on the evap canister located under the tail end of our xB's. Also hose issue at solenoid under the hood. These are the 3 main issues that I remember members having issues with.
Very helpful indeed! Thanks for this car tip
 
1 - 14 of 14 Posts
Top