Scion xB Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
Okay, I tried install new strut and springs today, but now, when ever I hit a bump (even a small small bump), the drver side is make so noise like some thing clicking. Anyone know what cause that?? I am very worry here, PLEASE HELP.

THANKS
 

·
Registered
Joined
·
352 Posts
most likely its because the aftermarket springs dont come with the bump stop like that stockers do, so everytime you hit the bump and the spring comes off that mount that little bit, it clicks
 

·
Registered
Joined
·
368 Posts
Did you make sure to re-install that little paper gasket?

Did you make sure to torque down the 17mm nut good ?

Did you get the spring install the proper direction ( top to bottom and seated)?

All of these can cause the noise.

Is the cv joint under stress?

Just a few suggestions to help.
 

·
Registered
Joined
·
611 Posts
i believe you forgot to put on the dust seal?

slowmo923 said:
#$%#...I forgot the about paper gasket, and I think I installed the struct cap wrong.

Thanks for the help~
 

·
Registered
Joined
·
192 Posts
well the only way i hear tha clicking is if i turn off tha radio lower my front window n as the car moves n i left off the gas but slow enough so theres minimal road noise but yeah ill get it checked at tha dealer
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top