Scion xB Forum banner
Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello there. On the way to work this morning 3 yellow lights came on. 1 check eng. 2 trac off 3 VSC it isnt driving different no smell no noise no problems. I did the dash reset thing wit the odometer but still nothing so anyone havean idea?
 

·
Registered
Joined
·
145 Posts
U can do the traction light.its letf of the steering wheel.long narrow buttin .VCS i have no idea and i know with the check engine light that i had that problem for a while.i needed water in my car and i know that when u get your oil changed something happens with it.(atleast for me)
 

·
Registered
Joined
·
1,420 Posts
Gas cap! I think that you have to go get it turned off. I hate EPA extra crap. Don't get me wrong I like the idea of helping the environment, but this is just annoying crap.
 

·
Registered
Joined
·
454 Posts
Any mods? if so which ones? did you fill up with gas before? if so check the gas cap and make sure it's tight.

If there is a sensor problem that the computer can see it will turn on all the indicator lights in the car. Could be something as simple as a loose gas cap to a more sinister problem. If the car is still under warranty a trip to the dealer might be in order.
 

·
Registered
Joined
·
45 Posts
my car has a cold air intake, and it does the same thing, i took it to toyota, but they could not find anything.

gas cap? right after i filled up yesterday i started driving and my batt light and a few others came on then my car dies, but now everything is fine.
even thoue my vsc light, trac light and check engen light do come on and off random times..... but .... ill talk to my scion dealer saterday about the gas thing. but how does the gas cap afect the vsc?

i was just about to post this same post... thanks, and good to know that im not the only one!!::(
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
my rig is just lowered it has strut stabilizer and wing on back so nothing messed with the enigine or exhaust
 

·
Registered
Joined
·
454 Posts
I would recommend the dealer if you still have the warranty. If not go to autozone or one of those places, or see if a friend has a scanner. Hook up to the car's computer and see the code.

Depending on the code you get you'll have to proceed from there.
Several xB owners have had a problem with the camshaft POS sensor. If you haven't been keeping up with maintenance you might need a tune up (ie misfire codes) there was one case where a guy had a misfire code and it turned out to be a faulty fuel injector. However first and foremost you need to see what the computer is seeing so that you can proceed with the next step. The dealer might charge you just to check it out if it isn't under warranty. Good luck
 

·
Registered
Joined
·
454 Posts
the gas cap doesn't neccessarily affect the vsc or trac lights.

Basically. . .
When ever the check engine light (CEL or MIL) comes on, all the lights do. VSC, TRAC, CEL, and sometimes ABS why toyota did that I do not know. But I know from experience that they will all come on.

The gas cap thing is related to something called the "Evaporative" system which the CEL can come on for. Anyhow, to go into a further explanation I'd need to do some more serious research on how it works. Hopefully i didn't confuse you more.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
gas cap not the issue. so next step auto zone. but if plugs are needing replaced why would trac off light come on? but that may be te trouble I was just aout to tune it up
 

·
Registered
Joined
·
1,479 Posts
As Ghost1 indicated, anytime you get a CEL the TRAC and VSC lights come on as well. It is just standard operating procedure on the xB. I went through this for quite a while on the wife's car.

If you are lucky enough to find a scanner that works, that can tell you what the problem is. Unfortunately, very few of the aftermarket scanners that you can get a hold of easily can actually read the codes off of the xB. I rented (purchased and waited almost a week for a refund) a scanner from a local AutoZone. I spent more than an half an hour just trying to get the scanner to work. (These things are idiot proof.) Never did get it to scan the ECU, and that was with an active CEL!

I also went to another shop here in town and they were unable to pull the CEL code as well. That was the end of my options short of going to the dealer. Until the dealer could actually look at it I would just pull the EFI fuse under the hood. (This will reset the ECU.) Just be careful doing this. If you have a real problem, you want to get it addressed.

In the end the dealer finally got to look at the car with the CEL on. Turned out to be the cam position sensor. A pretty quick fix, but an issue that could have become a big problem if not addressed.

Bottom line? Don't take a CEL in the xB (or any car) for granted. Get it scanned a.s.a.p. and address the problem. Especially in the xB since there are known issues (like mine) that could be catastrophic for a motor if not addressed. And if a dealer finds out you are resetting the ECU and get a failure you may have a real hard time being covered under the factory warranty.
 

·
Registered
Joined
·
491 Posts
Hello there. On the way to work this morning 3 yellow lights came on. 1 check eng. 2 trac off 3 VSC it isnt driving different no smell no noise no problems. I did the dash reset thing wit the odometer but still nothing so anyone havean idea?
i had the same thing happen to me, but i knew right away what the problem was and had it fix pronto....it ended up being the mass air flow sensor...if you have a short ram or a cai. they usaully blow the sensor if the intake i pulling the wrong amount of air or if there's dirt or dust getting in somewhere! you can get a can of air in napa or any auto part store and blow the sensor clean , if that don't work your best bet is the mas........jus a dent in the wallet for a little piece of plastic if your not under warranty! check out the old thread with this problem http://www.clubxb.com/forums/f60/4713-having-problems/
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top