Scion xB Forum banner
21 - 40 of 69 Posts

·
†-LoSt-†
Joined
·
2,146 Posts
My xb1 isstarting to do this, but it sounds like its coming from the top of the winshueld, or where the headliner attaches.........uber annoying.

Sent from my Droid using Tapatalk
 

·
Registered
Joined
·
6 Posts
hey, me too, like i said... when its cold, there is a click noise as well... i think mine is from the bottom part of the windshield, passenger side...

I asked scion dealership (the director who sold it to me), and he said if it continues, to bring it in and they'll see what they can do... like come on... brand new and already this... i've only had mine for 2 weeks!
Other than that... its great!
what kind of mileage are you getting... mine is at 9.0L/100km...
quick question. when my gas light came on and when it said there was about 14km left of range, I filled up the tank and it took only 43 liters, which i don't understand cuz the tank is 53!!! Does that mean i can drive beyond what the range tells me?
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #24 ·
what kind of mileage are you getting... mine is at 9.0L/100km...
quick question. when my gas light came on and when it said there was about 14km left of range, I filled up the tank and it took only 43 liters, which i don't understand cuz the tank is 53!!! Does that mean i can drive beyond what the range tells me?
Please discuss this in a different thread which relates to mileage.

Thanks
 

·
Registered
Joined
·
65 Posts
I haven't noticed anything on my 2011 xb. Then again most of these posts mention that it only happens when it's cold.

aaaaand it never really gets cold here, maybe 60degree's the absolute lowest lol.
 

·
Registered
Joined
·
60 Posts
Discussion Starter · #31 ·
Mine has been doing this before the cold weather hit.
 

·
Registered
Joined
·
417 Posts
im at the dealership right now getting the clicking noise looked at. the windshield ticking is chalked up the the fact that the gasket hardens and shrinks causing the tick. the other noise i have they cant figure out. they are ripping the car apart and seeing what they can find.
 

·
Registered
Joined
·
65 Posts
Hmm, about a week ago I posted saying that I don't have that window creek, and I'm still not experiencing it but now I heard a tick tock sound that my xb never made. This only happens on the first setting.

Sounds like I have a loud clock in my dash lol
 

·
Rockin' a 7
Joined
·
67 Posts
same problem on my 08, sounds like its coming when the bottom of the glass where the glass meets the left and right pillars. Creeks when I hit bumps, but for the most part it only happens when the weather is cold.
Yeah, same here. Only when it's cold. It kinda pisses:mad: me off too because I had a 2010 5-speed BSP that I traded in for a 2010 RS7 and my BSP never made that noise. The only reason (to me) that made it worth trading a 2010 for another 2010 was because I would get a lot more features on the release series, but unfortunately along with those extra features I got a creaking noise. Mine only comes from the bottom on the driver's side.

I read on another thread on another forum (I know, really descriptive right? LOL) that sometimes if the creaking sound is coming from the area near the bottom of the a-pillar that it could be the plastic trim of the a-pillar rubbing on the plastic of the dash when your car flexes. I am hoping this is the case with mine because it is a very easy fix.
 

·
Rockin' a 7
Joined
·
67 Posts
Oh yeah, since this seems to be due to body flex, does anyone reporting this problem have a strut tower brace? I would be interested to know if this would fix this problem.
 

·
Registered
Joined
·
7 Posts
I fixed mine on my RS 5.0 by installing some foam weather stripping between the bottom of the windshield and the black plastic cowl. In the cold, the windshield shrinks and then the cowl can move and rub a little bit causing creaking or squeaking. I removed the cowl, cleaned the bottom of the glass and stuck on some 1/4" wide, 3/8" thick foam weather stripping. This was probably too thick but I was able to compress the foam a lot when I re-installed the cowl. It just made it more difficult to refit the cowl around the bottom of the glass. I was pumped when i test drove my ride an had no noises just like it is in the summer time!
 

·
Registered
Joined
·
13 Posts
agree with Rjjone2. I had the same issue. sounded like coming from the windshield corners, top and bottom. Some thin, adhesive neoprene foam fixed the issue entirely. I just put it on the drivers side, didn't even finish the passenger side wiper try and the issue resolved. I have some of the tape left over if you are interested. Just pm me. It is very thin and inconspicuous.
 

·
Registered
Joined
·
5 Posts
I guess its kind of related, my wifes 2010 started making a really loud whistling sound when she would get up to about 70ish. The dealership had to order a new seal for the windshield and its going in Mon. for the repairs.
 

·
Dude, I'm only 17..
Joined
·
333 Posts
hmm i didnt post in here yet, anyways, at 5k we started hearing rattling and squeaking noises. took it to toyota told them i think the a-pillar bolts are loose, and the cowl is making the noise, they said that the pillar bolts werent loose but needed insulation. guy told me they drove it without the interior cover and they couldnt hear anything. anyways for they cowl they said they insulated that too.
 
21 - 40 of 69 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top