AC not working, possible electrical issue? - Scion xB Forum
 
LinkBack Thread Tools
post #1 of 1 Old 10-04-2017, 03:30 PM Thread Starter
Registered User
 
Join Date: Oct 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
SashaH90 is on a distinguished road
(Thread Starter)
AC not working, possible electrical issue?

Ok so I've got an 2010 Scion XB. Well about two weeks ago the AC just quit. Cold in the morning, ran to the store and hot after i left the store. So when i got home i put on my gauges. Well both gauges were pegged as far as they could go. So i figured the compressor blew. Changed the compressor, desicant, and pretty much everything else except for the ac lines themselves. Well, closed everything up, pulled a vacuum for 6 hours just cause. Let it sit for one hour and confirmed i had good seal. Refilled it with 17 oz of r-134a and 4.5ozs of pag oil. I can't get the compressor to kick on at all. Jump it at the high pressure switch and the compressor will kick on and immediatly gets cold. When the compressor kicks on all my pressures are good. Low side drops to 29-34 and high side hangs around 150. Remove my jumper wire then nothing again. Could my high pressure switch have failed?
SashaH90 is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome