Trouble code P0171. Help please? - Scion xB Forum
Scion xB Engine, Tech, & Performance Discuss Scion xB engine, tech, & performance related topics here. Scion xB performance upgrades like Scion xB exhaust, Scion xB turbos and supercharges. Anything to make your Scion xB go fast!!!

 
LinkBack Thread Tools
post #1 of 10 Old 07-19-2013, 06:47 PM Thread Starter
Registered User
 
Join Date: Feb 2011
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bluestar is on a distinguished road
(Thread Starter)
Trouble code P0171. Help please?

3 dash lights came on and I took the car to Autozone for the code. Trouble code P0171 came up. Anyone know what I should do/check first? Thanks

Oh, and is it bad if I keep driving it normally?
bluestar is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 07-19-2013, 06:57 PM
resident old fart
 
Toy_Yoda's Avatar
 
Join Date: Mar 2011
Location: Fullerton California
Posts: 2,075
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Toy_Yoda will become famous soon enough
Garage
Re: Trouble code P0171. Help please?

That's the code for "system too lean". I'd check for a vacume leak upstream of the MAF sensor.
Toy_Yoda is offline  
post #3 of 10 Old 07-19-2013, 07:09 PM Thread Starter
Registered User
 
Join Date: Feb 2011
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
bluestar is on a distinguished road
(Thread Starter)
Re: Trouble code P0171. Help please?

Thanks. Where can I find the MAF sensor?
bluestar is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 07-19-2013, 08:55 PM
Undercover Moderator
 
DTRAIN619's Avatar
 
Join Date: Dec 2005
Location: In Da Garage!
Posts: 16,198
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 96 Post(s)
DTRAIN619 is a jewel in the rough DTRAIN619 is a jewel in the rough DTRAIN619 is a jewel in the rough
Garage
Re: Trouble code P0171. Help please?

Quote:
Originally Posted by bluestar View Post
Where can I find the MAF sensor?
DTRAIN619 is offline  
post #5 of 10 Old 01-14-2014, 08:41 AM
resident old fart
 
Toy_Yoda's Avatar
 
Join Date: Mar 2011
Location: Fullerton California
Posts: 2,075
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Toy_Yoda will become famous soon enough
Garage
Re: Trouble code P0171. Help please?

Glad this thread is still open! Thought I'd share a discovery I found yesterday when I got a code P0171 myself. For years I've had my purge valve mounted on my strut bar after going to a short ram intake. Yesterday I removed the strut bar to install a header and left the purge valve just supported by it's vacume hoses. During the header install, it moved into a horizontal position. I kept getting a code P0171 that would return after only about 5 miles of driving. Once I discovered that the purge valve had moved and restored it to it's original position; no more codes. Long story made short; keep the purge valve in an upright position!
Toy_Yoda is offline  
post #6 of 10 Old 01-14-2014, 05:37 PM
Undercover Moderator
 
DTRAIN619's Avatar
 
Join Date: Dec 2005
Location: In Da Garage!
Posts: 16,198
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 96 Post(s)
DTRAIN619 is a jewel in the rough DTRAIN619 is a jewel in the rough DTRAIN619 is a jewel in the rough
Garage
Re: Trouble code P0171. Help please?

Good tip, Brother Rich!
DTRAIN619 is offline  
post #7 of 10 Old 02-26-2014, 08:04 PM
Registered User
 
easternshorebox06's Avatar
 
Join Date: Mar 2010
Location: Maryland
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
easternshorebox06 is on a distinguished road
Re: Trouble code P0171. Help please?

any updates? I'm getting same code when I come to stop or idle. no codes while driving. cleaned maf sensor already

meanness and kindness can both be contagious.... which do you want to spread?
easternshorebox06 is offline  
post #8 of 10 Old 02-26-2014, 09:02 PM
resident old fart
 
Toy_Yoda's Avatar
 
Join Date: Mar 2011
Location: Fullerton California
Posts: 2,075
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Toy_Yoda will become famous soon enough
Garage
Re: Trouble code P0171. Help please?

Shortly after my last post to this thread, the P0171 code started to return, but just as you have said never while driving, but only at idle at a light. Even drove over 100 miles on the freeway with no problems, but got the code again about 5 miles after getting back on surface streets. Can't find any trace of a vacuum leak, so I've come to suspect one of the injectors is not working correctly at low demand. Usually don't trust "miracles in a can" type cures, but I've added Redline fuel system cleaner at the last fill-up. Only driven about a quarter tank since then, but the code seems to be reoccurring less frequently, but is still happening. I'll report back at the end of this tank. Keeping my fingers crossed.
Toy_Yoda is offline  
post #9 of 10 Old 02-26-2014, 10:02 PM
Registered User
 
easternshorebox06's Avatar
 
Join Date: Mar 2010
Location: Maryland
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
easternshorebox06 is on a distinguished road
Re: Trouble code P0171. Help please?

thanks, last time I had this I cleaned my MAF sensor and added couple cans of seafoam to tank fills and it cleared up. that was about 100,000 miles ago.

meanness and kindness can both be contagious.... which do you want to spread?
easternshorebox06 is offline  
post #10 of 10 Old 03-25-2014, 11:51 AM
Registered User
 
easternshorebox06's Avatar
 
Join Date: Mar 2010
Location: Maryland
Posts: 351
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
easternshorebox06 is on a distinguished road
Re: Trouble code P0171. Help please?

Update: was getting the PO171 code primarily and occasional PO441 and PO455 with it (not always). It would give a fit when trying to start after filling up the tank also. I cleaned my MAF again, replaced PCV, air filter, and went through a can of Seafoam fuel treatement and two bottles of Lucas fuel additive over course of couple weeks and last Friday lights stay off. I liked to top off and may have done to much once so I made sure not to top off excessively anymore either. maybe dirty injector or vapor lock that cleared up? anyhow, no longer getting codes so all is good again.

meanness and kindness can both be contagious.... which do you want to spread?
easternshorebox06 is offline  
Reply

User Tag List




Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome