Code PO301 HELP - Scion xB Forum
Scion xB Engine, Tech, & Performance Discuss Scion xB engine, tech, & performance related topics here. Scion xB performance upgrades like Scion xB exhaust, Scion xB turbos and supercharges. Anything to make your Scion xB go fast!!!

 
LinkBack Thread Tools
#1 Old 03-17-2007, 02:48 PM
Registered User
 
kzhorse's Avatar
 
Join Date: Apr 2006
Location: Dundalk,Maryland
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kzhorse is on a distinguished road
(Thread Starter)
Code PO301 HELP

Ok where to begin I have a 05 xB M5 with 54,777 I finally got my first check engine this morning (PO301) If I am correct cylinder #1 misfire so I changed the plugs and it still shakes and only takes about 3 blocks to get the light again,So I swaped the coil pac from #1 to #2 still the same code. comes back after reset.
What else could it be?I am thinking it has something to do with the 2"+ of rain we got yesterday then turned to sleet last night.
I drove for over 100 miles yesterday in all the heavy rain and all was normal till this morning when I went out for coffee.

Thanks for looking,Scott

05 Camo xB M5,Carrozzeria/Pioneer FH-P909MD,Home made tower brace,Proline Products Roof Rack.Carbon fiber spoiler,WADEventshades,AVS bugshield,aitracing CF Hood,led strip under dash & led's in cupholders.Glass rally shifter,Custom dual exhaust.




http://www.strictlyscionized.com/
kzhorse is offline  
Sponsored Links
Advertisement
 
#2 Old 03-17-2007, 03:06 PM
Registered User
 
Join Date: Feb 2006
Location: NOT HERE
Posts: 368
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Frogbox is on a distinguished road
Just a couple questions.
Did you use boot grease ?
Did you use anti seize on the plugs ?
Did you clean the head where the coil packs bolt on ?

I found without boot grease I got a misfire.
I found that anti seize on the electroids of the spark plugs did the same.
And the ground connection of the coil pack to head needed to be scraped clean of any oxcidation to get a good clean spark.

also may want to check the coil pack plug connection to make sure they are clean ( used brake clean spray). these were all problems and corrections i found work one time or another for me.

When your Ignore list is bigger than your buddy list it is time to move on.
Frogbox is offline  
#3 Old 03-17-2007, 03:17 PM
Registered User
 
kzhorse's Avatar
 
Join Date: Apr 2006
Location: Dundalk,Maryland
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kzhorse is on a distinguished road
(Thread Starter)
Did you use boot grease ? No
Did you use anti seize on the plugs ? Yes,light coat on threads none on electrode
Did you clean the head where the coil packs bolt on ? Yes

Still runs rough and has a bad misfire.


Scott

05 Camo xB M5,Carrozzeria/Pioneer FH-P909MD,Home made tower brace,Proline Products Roof Rack.Carbon fiber spoiler,WADEventshades,AVS bugshield,aitracing CF Hood,led strip under dash & led's in cupholders.Glass rally shifter,Custom dual exhaust.




http://www.strictlyscionized.com/
kzhorse is offline  
#4 Old 03-17-2007, 06:08 PM
Registered User
 
scowiii's Avatar
 
Join Date: Feb 2007
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
scowiii is on a distinguished road
take all the plugs and wires and dry them off real good and also look at the ports and try to clean any excess water that may be in there and then put everything back on and you should be good to go.
scowiii is offline  
#5 Old 03-17-2007, 08:15 PM
That Guy
 
ShortBus's Avatar
 
Join Date: May 2006
Location: Sulphur, LA
Posts: 1,420
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ShortBus is on a distinguished road
I have a Toyota mechanic in my house now. This is what he says to do in order.

Starting point
plug
coil check
check compression
harness to the computer

Robert

Never underestimate the power of a lot of stupid people.[COLOR="Black"]
Pics Police, "Deputy"
ShortBus is offline  
#6 Old 03-18-2007, 10:04 AM
Registered User
 
kzhorse's Avatar
 
Join Date: Apr 2006
Location: Dundalk,Maryland
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kzhorse is on a distinguished road
(Thread Starter)
Quote:
Originally Posted by ShortBus View Post
I have a Toyota mechanic in my house now. This is what he says to do in order.

Starting point
plug
coil check
check compression
harness to the computer
The plugs were changed first the coil was switched twice now with #2 and #4 still same problem and code.I dont have a compression tester so that is out.
This morning I checked all connections for corosion and shot them with Silicon spray still doing the same thing.
This leads me to believe that I have a bad injector or dirty when I unplug #1 injector I get no difference in the way it runs but when I unplug any of the other 3 it really bogs down and shakes BAD.
Now to figure out how to remove the injector and swap it with another.


Scott

05 Camo xB M5,Carrozzeria/Pioneer FH-P909MD,Home made tower brace,Proline Products Roof Rack.Carbon fiber spoiler,WADEventshades,AVS bugshield,aitracing CF Hood,led strip under dash & led's in cupholders.Glass rally shifter,Custom dual exhaust.




http://www.strictlyscionized.com/
kzhorse is offline  
#7 Old 03-19-2007, 05:13 PM
Registered User
 
Join Date: Oct 2006
Posts: 1,243
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 57 Post(s)
rton20s is on a distinguished road
Looks like you are following the logic I was going to point you to. With everything you have done on the plugs and coil packs, it leads me to believe you have a fuel issue, not a spark issue. Make sure that all of your connections are good for the injectors. Then swap out injectors, just like you were saying.

I just ran into this same problem, starting last night, on a Prelude I am looking to sale. P0302 for me... misfiring in cylinder 2. (Same codes are used). I know I need new plugs anyway, so I am starting with that right after work today. I'm hoping that mine is a spark issue, as it much cheaper to address when you are out of warranty.

Good luck on chasing down your problem. And keep us updated with what you find out. It might be worth it to just take it into the dealer if you aren't out of warranty yet.
rton20s is offline  
#8 Old 03-19-2007, 06:13 PM
Registered User
 
kzhorse's Avatar
 
Join Date: Apr 2006
Location: Dundalk,Maryland
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kzhorse is on a distinguished road
(Thread Starter)
I cant track down a compresion tester and I dont like running on 3 so it goes to the dealer tommorrow.I just hope it is covered under warranty.If I'm not mistaken it is 3/60K on power train and I did get the extended warranty for 5/100k.
I will let you know what they find.and I didnt switch the injectors I was not sure on what I was doing.


Scott

05 Camo xB M5,Carrozzeria/Pioneer FH-P909MD,Home made tower brace,Proline Products Roof Rack.Carbon fiber spoiler,WADEventshades,AVS bugshield,aitracing CF Hood,led strip under dash & led's in cupholders.Glass rally shifter,Custom dual exhaust.




http://www.strictlyscionized.com/
kzhorse is offline  
#9 Old 03-19-2007, 06:52 PM
Registered User
 
Simplyscion's Avatar
 
Join Date: Jan 2006
Location: Long Island NY
Posts: 131
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Simplyscion is on a distinguished road
powertrain is 5yr 60K miles so your good still...your extended warranty that you purchased is probly a bumper to bumper extention which originally is 3 yr 36k miles but is now 5yr 100k miles...that is unless you opted to extend the powertrain warranty...the default Scion warranties are bumper to bumper extentions

04' Boostbox(sold)
05' Yamaha Raven R6
06' blown tC- totalled
06' Acura TSX-Premium White Pearl
Smithtown Scion 631-724-3300
Smithtownscion.com
Call and ask for Vito!!
Smithtown Scion rated top volume dealer in Tri State area for 2006
Simplyscion is offline  
#10 Old 03-19-2007, 08:01 PM
Registered User
 
Join Date: Oct 2006
Posts: 1,243
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 57 Post(s)
rton20s is on a distinguished road
And if the warranties are the same nation wide, I believe they extend to 7 year / 100k miles. I only know because my wife opted to get the extended warranty on her car.
rton20s is offline  
#11 Old 03-20-2007, 10:01 AM
Registered User
 
kzhorse's Avatar
 
Join Date: Apr 2006
Location: Dundalk,Maryland
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kzhorse is on a distinguished road
(Thread Starter)
Well I walked out of the dealer after they charged me $89 they tell me that if requires new plugs before they can check any further another $80 I dont think so,I told them it has good spark but no fuel.
So I just swaped injectors now #2 is not firing, So now I have another Dealer to list That will never see me for service and I hope Toyota dont send me a survey on them.


Scott

05 Camo xB M5,Carrozzeria/Pioneer FH-P909MD,Home made tower brace,Proline Products Roof Rack.Carbon fiber spoiler,WADEventshades,AVS bugshield,aitracing CF Hood,led strip under dash & led's in cupholders.Glass rally shifter,Custom dual exhaust.




http://www.strictlyscionized.com/
kzhorse is offline  
#12 Old 03-20-2007, 11:08 AM
Registered User
 
Join Date: Oct 2006
Posts: 1,243
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 57 Post(s)
rton20s is on a distinguished road
Sucks man. At least you pretty much have it narrowed down to an injector now.

I started on my Prelude last night. Swapped out all of the plugs, because they needed replacing anyway, then reset the ecu. It ran great for a few minutes, but as soon as I put the car under a heavy load in second merging onto the freeway the car began to sputter again. CEL came up again as well.

At that point I just took the car home and parked it. I think I'll be calling a mechanic I know to get the car in. I just don't have the time, or a scan tool at home to diagnose the problem correctly.

Let us know how the new dealer treats you, and how it turns out.
rton20s is offline  
#13 Old 03-20-2007, 11:53 AM
Registered User
 
kzhorse's Avatar
 
Join Date: Apr 2006
Location: Dundalk,Maryland
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kzhorse is on a distinguished road
(Thread Starter)
Re: Code PO301 HELP

Well I called around to find a new injector $90+ and about a week to get so off to EZ-Pickens (Junk yard) for $13.50 I got 3 injectors and a engine cover Changed it outside the junk yard runs like a top.I gave the faulty/cloged injector to the dealer and Thanked them for nothing.All they had to do was there job check it out and I would have been more than willing to pay for a injector cleaning so they are going to get complained about to Toyota and lost another $100+.

Scott

05 Camo xB M5,Carrozzeria/Pioneer FH-P909MD,Home made tower brace,Proline Products Roof Rack.Carbon fiber spoiler,WADEventshades,AVS bugshield,aitracing CF Hood,led strip under dash & led's in cupholders.Glass rally shifter,Custom dual exhaust.




http://www.strictlyscionized.com/
kzhorse is offline  
#14 Old 03-20-2007, 12:07 PM
Registered User
 
Join Date: Oct 2006
Posts: 1,243
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 57 Post(s)
rton20s is on a distinguished road
Re: Code PO301 HELP

Very nice to see you got the issue resolved. Especially for such a reasonable price.

Unfortunately with my lack of time, lack of a scan tool, and the difficulty in accessing the injectors on my Prelude, I already called my mechanic. It will be worth it in the end to spend a few bucks with him not to have to chase rabbits and play contortionist swapping out injectors, etc.

The only thing that sucks is that I am trying to sell the car. It will be fixed, and fixed right. But if the buyer takes the car to a mechanic (and they know what they are doing) they'll be able to tell the last time a code was cleared on the car. I did some research and it takes something like 60-80 full warm up cycles on the engine to completely clear the ecu.
rton20s is offline  
#15 Old 03-20-2007, 12:23 PM
Registered User
 
kzhorse's Avatar
 
Join Date: Apr 2006
Location: Dundalk,Maryland
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
kzhorse is on a distinguished road
(Thread Starter)
Re: Code PO301 HELP

Not sure on that I was told 5 run cycles.
But thanks for conversing with me on this subject and I wish youluck with the repairs and sale.


Scott

05 Camo xB M5,Carrozzeria/Pioneer FH-P909MD,Home made tower brace,Proline Products Roof Rack.Carbon fiber spoiler,WADEventshades,AVS bugshield,aitracing CF Hood,led strip under dash & led's in cupholders.Glass rally shifter,Custom dual exhaust.




http://www.strictlyscionized.com/
kzhorse is offline  
#16 Old 03-22-2007, 12:59 PM
Registered User
 
Join Date: Oct 2006
Posts: 1,243
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 57 Post(s)
rton20s is on a distinguished road
Re: Code PO301 HELP

Not that anyone actually cares, but I got the P0302 code in my Prelude resolved as well. Turns out the Magnacor wires had outlived their usefulness.

I was going to swap wires myself next, but didn't want to be chasing my own tail without the use of the scanner. All in all it cost me about $80 more than I would have spent doing it on my own. And to me that $80 was well worth my time not worrying about it or having to get my own knuckles bloody swapping around injectors, etc.

So... anybody wanna buy a '98 Prelude Type SH that now runs like a top with brand new plugs and wires?
rton20s is offline  
Closed Thread

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome